Blue temp icon appears upon start-up. Is that normal? - Honda Fit Forum : Honda Fit Forums
» Auto Insurance

FITOwnersClub.com is the premier Honda Fit Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 06-18-2020, 12:12 PM   #1
Nevadatude
Junior Member
 
Join Date: Jun 2020
Posts: 1
Default Blue temp icon appears upon start-up. Is that normal?

Hi,
I bought the 2019 Fit 3 weeks ago. A blue temperature icon appears when I start the car. It disappears in about a minute. Is that normal? Should I wait for the light to disappear before I drive the car? Thanks
Nevadatude is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-25-2020, 08:31 PM   #2
mbenazeraf
Junior Member
 
Join Date: Dec 2019
Location: Corpus Christi, Texas
Posts: 1
Default

Quote:
Originally Posted by Nevadatude View Post
Hi,
I bought the 2019 Fit 3 weeks ago. A blue temperature icon appears when I start the car. It disappears in about a minute. Is that normal? Should I wait for the light to disappear before I drive the car? Thanks
Yes NORMAL. Simply to let you know that the engine is not up to ideal temperature. Yes, it is safe to start rolling, it will go off quickly.
mbenazeraf is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 12:25 PM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.